POJ 2262

简介:

In 1742, Christian Goldbach, a German amateur mathematician, sent a letter to Leonhard Euler in which he made the following conjecture:  Every even number greater than 4 can be written as the sum of two odd prime numbers.
For example:
8 = 3 + 5. Both 3 and 5 are odd prime numbers.
20 = 3 + 17 = 7 + 13.
42 = 5 + 37 = 11 + 31 = 13 + 29 = 19 + 23.
Today it is still unproven whether the conjecture is right. (Oh wait, I have the proof of course, but it is too long to write it on the margin of this page.)
Anyway, your task is now to verify Goldbach's conjecture for all even numbers less than a million.

Input

The input will contain one or more test cases.
Each test case consists of one even integer n with 6 <= n < 1000000.
Input will be terminated by a value of 0 for n.

Output

For each test case, print one line of the form n = a + b, where a and b are odd primes. Numbers and operators should be separated by exactly one blank like in the sample output below. If there is more than one pair of odd primes adding up to n, choose the pair where the difference b - a is maximized. If there is no such pair, print a line saying "Goldbach's conjecture is wrong."

Sample Input

8
20
42
0

Sample Output

8 = 3 + 5
20 = 3 + 17
42 = 5 + 37

这个题的意思就是说偶数可以由两个奇数而且还是素数的和组成,所以我们就求和呗



代码如下:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int maxn=1e6;
int data[maxn];
void sushu()
{
     memset(data,1,sizeof(data));
     for(int i=2;i<maxn;i++)
     {
         if(data[i]) for(long long j=(long long)i*i;j<maxn;j+=i)
            data[j]=0;
     }
}
bool odd(int m)
{
     if(m%2)return 1;
     return 0;
}
int main()
{
    sushu();
    int m;
    while(cin>>m&&m)
    {
        cout<<m<<" = ";
        for(int i=3;i<=m/2;i++)
        {
            int n=m-i;
            if(odd(i)&&odd(n))
            {
                if(data[i]&&data[n])
                {
                    cout<<i<<" + "<<n<<endl;
                    break;
                }
            }
        }
    }
    return 0;
}

目录
相关文章
POJ 2027 No Brainer
POJ 2027 No Brainer
82 0
|
测试技术
POJ 1001
此题用最朴素的思路实现即可,需模拟加法器,乘法器,最烦人的地方是特殊情形,如末位是小数点(12.^2=144,取小数点),整数末位是0(100^2=10000),0次幂,测试用例可能超出题目中说的范围,可能包含0次幂(100.0^0=0, 0.10^1=0.1)。
728 0
poj 2299 求逆序数
http://poj.org/problem?id=2299 #include using namespace std; int aa[500010],bb[500010]; long long s=0; void merge(int l,int m,int r) { ...
766 0
|
机器学习/深度学习
|
机器学习/深度学习
|
机器学习/深度学习
POJ 1328
1 2 //坐标精度是int 3 /* 4 圆心位于 5 */ 6 #include 7 #include 8 #include 9 #include 10 using namespace std; 11 12 const int N =...
849 0