hdu 1028 Ignatius and the Princess III (母函数)

简介:

点击打开链接

Ignatius and the Princess III

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16394    Accepted Submission(s): 11552


Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
 

Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
 

Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
 

Sample Input
 
 
4 10 20
 

Sample Output
 
 
5 42 627
 

Author
Ignatius.L
 

Recommend
We have carefully selected several similar problems for you:   1171  1085  1398  2152  1709 
 

题目大意:

就是将一个数 n 拆分成无序可以重复的数,可以几种方法。。

解题思路:

母函数。。。

(1+x+x^2+x^3+.....+x^n)*(1+x^2+x^4+....)*(1+x^3+x^6+...)*...

直接上代码:(可以当作模板)

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <vector>
#include <queue>
#include <algorithm>
#include <set>
using namespace std;

#define MM(a) memset(a,0,sizeof(a))

typedef long long LL;
typedef unsigned long long ULL;
const int maxn = 1e6+5;
const int mod = 1e9+7;
const double eps = 1e-8;
const int INF = 0x3f3f3f3f;
LL gcd(LL a, LL b)
{
    if(b == 0)
        return a;
    return gcd(b, a%b);
}
int c1[maxn];///每一次存的多项式中的数
int c2[maxn];///中间变量
int n;///拆分的数

/**
首先对c1初始化,由第一个表达式
(1+x+x^2+..x^n)初始化,
从0到n的所有x前面的系数都初始化为1.
**/
void Init()
{
    for(int i=0; i<=n; i++)
    {
        c1[i] = 1;
        c2[i] = 0;
    }
}

int main()
{
    while(cin>>n)
    {
        Init();
        for(int i=2; i<=n; i++)///控制一共循环几次,也就是每个多项式乘几次
        {
            for(int j=0; j<=n; j++)///第一个表达式的系数
            {
                for(int k=0; k+j<=n; k+=i)///我们只需要 n 前面的系数
                {
                    c2[k+j] += c1[j];
                }
            }
            for(int j=0; j<=n; j++)///我们在用 c1[]当作第一个乘
            {
                c1[j] = c2[j];
                c2[j] = 0;///c2不需要
            }
        }
        cout<<c1[n]<<endl;
    }
    return 0;
}


目录
相关文章
LeetCode 70. Climbing Stairs
你正在爬楼梯。 它需要n步才能达到顶峰。 每次你可以爬1或2步。 您可以通过多少不同的方式登顶? 注意:给定n将是一个正整数。
40 0
LeetCode 70. Climbing Stairs
AtCoder Beginner Contest 221 E - LEQ(组合数学 树状数组)
AtCoder Beginner Contest 221 E - LEQ(组合数学 树状数组)
129 0
CodeForces 1195C Basketball Exercise (线性DP)
CodeForces 1195C Basketball Exercise (线性DP)
84 0
|
测试技术
HDU-1026,Ignatius and the Princess I(BFS+打印路径)
HDU-1026,Ignatius and the Princess I(BFS+打印路径)
HDU-1027,Ignatius and the Princess II
HDU-1027,Ignatius and the Princess II
HDU-1029,Ignatius and the Princess IV
HDU-1029,Ignatius and the Princess IV
hdu-1098 Ignatius's puzzle(费马小定理)
hdu-1098 Ignatius's puzzle(费马小定理)
125 0
hdu-1098 Ignatius's puzzle(费马小定理)
|
Java C语言
HDOJ/HDU 1029 Ignatius and the Princess IV(简单DP,排序)
HDOJ/HDU 1029 Ignatius and the Princess IV(简单DP,排序)
118 0
|
人工智能
HDOJ 1028 Ignatius and the Princess III(递推)
HDOJ 1028 Ignatius and the Princess III(递推)
98 0